通达信指标公式分享:定海神针

步子 1999-10-29 12:23:17 热度:9504°C

本来想分享一下多年来的一些学习和研究文档, 但是因为资质问题一直无法通过, 所以接下来给大家分享一些不错的指标公式,都是附带源码的.

先来看下效果图:

公式里用到了未来函数, 懂得技术分析的朋友可以自己调节.

指标公式源码如下:

A1:=EMA(C,12)-EMA(C,25);

通达信指标公式分享:定海神针

A2:=EMA(A1,6);

获利回吐:(A2>=0)*A2,COLORWHITE,LINETHICK0;

大黑马:(A2<0)*A2,COLORD4FF7F,LINETHICK0;

坚绝做空:(A1<0)*A1,COLORB00058,LINETHICK0;

买入持股:(A1>=0)*A1,COLORRED,LINETHICK0;

STICKLINE(A2>=0,A2,0,5,0),COLORWHITE;

STICKLINE(A2<0,A2,0,5,0),COLORD4FF7F;

通达信指标公式分享:定海神针

STICKLINE(A1<0,A1,0,5,0),COLORB00058;

STICKLINE(A1>=0,A1,0,5,0),COLORRED;

VAR8:=VOL>2*MA(VOL,30);

VAR9:="DMI.ADX"(12,6);

VARA:="DMI.ADXR"(12,6);

VARB:=CLOSE>MA(CLOSE,30) AND CLOSE

VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);

通达信指标公式分享:定海神针

VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))

VARF:=TROUGHBARS(3,15,1)<4;

VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);

VAR11:=IF(VARF=1,50,0);

多空:EMA((CLOSE-MA((2*CLOSE HIGH LOW)/4,30))/MA((2*CLOSE HIGH LOW)/4,30)*100,3),COLORWHITE;

0,COLORRED;

STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,15,0),COLORF00FF0;

STICKLINE(FILTER(VARF=1,5),50,0,8,0),COLORYELLOW;

DRAWTEXT(FILTER(VARF=1,3),25,"黑马"),COLORRED ;

STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW;

STICKLINE(多空>10,0,多空,0.95,0),COLORRED;

相关阅读
推荐阅读